Delay in disbursing USD donations made through UKOGF

Incident Report for Benevity

Resolved

Delayed USD funds have now been released.
Posted Apr 04, 2025 - 07:11 MDT

Identified

We’re currently experiencing a delay in disbursing USD donations made through the UK Online Giving Foundation (UKOGF) during February and donations set to be disbursed at the end of March. The issue stems from a processing delay with our banking partner. We’ve escalated the matter to our banking partner and will continue to share updates here as we work towards a resolution in partnership with them.
Posted Apr 02, 2025 - 10:23 MDT
This incident affected: Benevity Global Disbursements.