Versaic Application is slow in Production.

Incident Report for Benevity

Resolved

The issue has been fully resolved, and our team is taking necessary steps to prevent this from happening again in the future. We apologize for any inconvenience this may have caused.
Posted 3 days ago. Mar 28, 2025 - 16:27 MDT

Monitoring

The team has performed steps to address the performance issue of the Versaic application, and we are monitoring to ensure stability. If you continue to experience issues, please submit a support request. Thank you for your understanding.
Posted 4 days ago. Mar 28, 2025 - 11:25 MDT

Investigating

Versaic application is slow in production. We are currently investigating the issue. Our team is working diligently to resolve the issue as quickly as possible. We will continue to provide updates here, so please subscribe to this page for the latest information.
Posted 4 days ago. Mar 28, 2025 - 10:33 MDT
This incident affected: Community Investment (Enterprise (formerly Versaic by Benevity)).