Match Assurance AI Validation Degradation

Incident Report for Benevity

Resolved

This incident has been resolved.
Posted Jul 27, 2026 - 20:41 MDT

Identified

We have identified the cause of the issue affecting AI-powered validation of employee matching requests (Match Assurance) on the Benevity platform. Our team is working on a fix and we expect to have an update shortly.
Posted Jul 27, 2026 - 18:46 MDT
This incident affected: Donate and Volunteer (formerly Benevity Spark) (Donate and Volunteer Core Services).