Error Processing Indian Credit Cards
Incident Report for Benevity
Resolved
We’re pleased to announce that the issues causing certain credit card transactions to fail for donations made through Online Giving Foundation (India) have been fully resolved. Credit card transaction processing has been restored to normal and we are now accepting transactions without any disruptions.

We extend our gratitude for your patience as we collaborated with our service provider to address these issues. We encourage all users to proceed with their normal transactions without any hesitation.

Thank you for your understanding and ongoing support.
Posted Jun 13, 2023 - 10:06 MDT
Monitoring
We are pleased to inform you that the issue affecting non-ICICI Bank Card transactions has now been successfully resolved. Furthermore, updates have been made to address the problem affecting ICICI Bank cards and we are closely monitoring transactions to validate resolution.

Once we confirm that credit card transaction processing has been fully restored, we will provide an update. We appreciate your continued patience throughout this process.
Posted May 26, 2023 - 11:47 MDT
Update
Two issues have been identified that are causing some credit card transactions to fail for donations made through Online Giving Foundation (India). The first issue affects all card transactions and is now believed to be resolved pending further verification. The second issue is isolated to ICICI Bank cards and our processing partner is still working on a resolution directly with ICICI Bank.

We are continuing to monitor the situation closely and will provide updates on our Incident Response Page as we receive more information.

Thank you for your continued patience.
Posted May 08, 2023 - 08:33 MDT
Update
Our payment processor continues to work with their vendors to investigate why certain credit card transactions are failing for donation payments made through Online Giving Foundation (India). While the root cause of the issue is still being determined, it has been identified that the majority of the failures appear to be unique to MasterCard transactions and all Visa cards issued by the ICICI BANK LIMITED bank.

Resolution of this issue is a top priority for Benevity and we will provide updates on our Incident Response Page as more information becomes available.

Thank you for your patience.
Posted Apr 11, 2023 - 16:49 MDT
Update
Our payment processor is continuing to investigate why certain credit card transactions are failing for donation payment attempts made through Online Giving Foundation (India). While the root cause of the issue is still being determined, improvements have been made with debit cards and some credit cards.

Resolution of this issue is a top priority for Benevity and we will continue to provide updates on our Incident Response Page .

Thank you for your patience.
Posted Mar 31, 2023 - 14:27 MDT
Investigating
We’ve identified an issue where certain credit card transactions are failing at a high rate for donation payment attempts being made through Online Giving Foundation (India).

Users who encounter this error will receive a declined payment message. Their credit card will not be charged, and their donation transaction will be unsuccessful.

Benevity has escalated this situation with our payment processor and we’ll post an update once resolved.
Posted Mar 24, 2023 - 17:44 MDT
This incident affected: Benevity Spark.