Versaic: Direct Page Navigation Feature Temporarily Disabled

Incident Report for Benevity

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 12, 2026 - 11:13 MST

Update

Action Required: If any proposals were submitted using the Direct Page Navigation feature and appear to have missing information, please release those proposals for editing so submitters can re-enter their responses.
Posted Feb 09, 2026 - 15:17 MST

Investigating

We identified an issue affecting the Direct Page Navigation feature, which allows users to navigate between form pages by clicking page names at the top of the screen.

While we work on a fix, we have temporarily disabled the Direct Page Navigation feature. Users can continue to navigate forms using the "Next" and "Previous" buttons without any issues.

We apologize for any inconvenience and appreciate your patience.
Posted Feb 09, 2026 - 14:58 MST
This incident affects: Grants (Grants Advanced (formerly Versaic)).