Grants Essential Degraded Performance

Incident Report for Benevity

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2026 - 15:53 MDT

Identified

We have identified an issue with Benevity Grants Essential that is causing degraded performance for users. The cause has been identified and we are actively working on a resolution.
Posted Jun 25, 2026 - 15:39 MDT
This incident affects: Grants (Grants Essential (formerly Benevity Grants)).