Our cloud provider's services have fully recovered, and our sites are fully operational. Thank you for your patience and understanding.
Posted Feb 10, 2026 - 15:50 MST
Update
Our cloud provider's services are recovering, and site stability is restoring. Users may still see intermittent issues until a full recovery is achieved by the provider - we will continue to monitor until full resolution is achieved.
Posted Feb 10, 2026 - 15:04 MST
Identified
Our cloud provider is experiencing an Incident, impacting all of our client sites intermittently. We are awaiting further updates from our provider, and are monitoring closely.
Posted Feb 10, 2026 - 14:34 MST
Investigating
We are experiencing intermittent outages across all sites. This is being investigated with urgency, and we will update the status page when more information is available.
Posted Feb 10, 2026 - 14:22 MST
This incident affected: Donate and Volunteer (formerly Benevity Spark).