Grants Essential Performance Degraded

Incident Report for Benevity

Resolved

This incident has been resolved.
Posted Jun 25, 2026 - 13:36 MDT

Update

The issue has been identified and we are now monitoring to ensure there are no other issues or fallout.
Posted Jun 25, 2026 - 12:33 MDT

Update

We are continuing to monitor for any further issues.
Posted Jun 25, 2026 - 12:31 MDT

Update

We continue to see degraded performance for some users with Grants Essential. We continue to investigate the issue and are taking actions to mitigate.
Posted Jun 25, 2026 - 11:19 MDT

Update

We continue to see degraded performance for some users with Grants Essential. We continue to investigate / monitor this issue and will provide updates here as we learn more.
Posted Jun 25, 2026 - 10:26 MDT

Update

Grants Essential is currently experiencing degraded performance for some users. We are investigating this issue and will provide updates here as we learn more.
Posted Jun 25, 2026 - 09:50 MDT

Update

We are continuing to monitor for any further issues.
Posted Jun 25, 2026 - 09:37 MDT

Monitoring

Grants intermittent access issues occurred for a short period of time, are actively watching the issue at this time and still working on a root cause analysis.
Posted Jun 25, 2026 - 09:35 MDT
This incident affected: Grants (Grants Essential (formerly Benevity Grants)).