Versaic Program Overview Proposal Links Return 404 Not Found in Production

Incident Report for Benevity

Resolved

The issue affecting proposal lists in the Versaic Client Portal has been resolved. Normal functionality has been restored. We apologize for any disruption this caused.
Posted Aug 17, 2026 - 10:02 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 13, 2026 - 20:57 MDT

Identified

We are currently experiencing degraded functionality for proposal lists accessed via My workspace > Program Overview within the Versaic Client Portal.

Our team is actively investigating and working to restore normal behaviour. We will provide updates as more information becomes available.
Posted Aug 13, 2026 - 10:49 MDT
This incident affected: Grants (Grants Advanced (formerly Versaic)).