Versaic: Schedule Service - Duplicate Actions Detected

Incident Report for Benevity

Resolved

This incident has been resolved.
Posted Sep 19, 2025 - 17:13 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 18, 2025 - 12:17 MDT

Identified

We are currently investigating an issue where our system's scheduled services have triggered duplicate actions for some users, such as sending duplicate emails.

This issue may affect all clients. Our team has identified the cause and is actively working on a resolution.

We apologize for any inconvenience this may cause and appreciate your patience. We will provide an update as soon as the fix is deployed and validated.
Posted Sep 18, 2025 - 11:52 MDT
This incident affected: Community Investment (Enterprise (formerly Versaic by Benevity)).