Versaic - Eligible causes showing as 'Not Disbursable' for some clients

Incident Report for Benevity

Resolved

The issue has been fully resolved, and our team has verified that the cause disbursable status for the affected clients is resolved. Our team has taken all necessary steps to prevent this from happening again in the future. We apologize for any inconvenience this may have caused.
Posted Mar 27, 2025 - 16:07 MDT

Monitoring

The issue has been resolved, and we are monitoring to ensure stability. Thank you for your understanding.
Posted Mar 27, 2025 - 15:46 MDT

Identified

We have identified an issue on Versaic affecting some organizations where they are showing as 'Not Disbursable'.
Our team is actively working on a fix, which includes both a system update and correcting the data for affected causes. We will keep you posted on the progress and next steps shortly. Thanks for your patience!
Posted Mar 27, 2025 - 12:44 MDT
This incident affected: Community Investment (Enterprise (formerly Versaic by Benevity)).