Causes Portal - Okta Login and Password Reset Issues

Incident Report for Benevity

Resolved

The incident has been resolved. We apologize for any inconvenience this may have caused.
Posted Mar 20, 2026 - 15:52 MDT

Monitoring

We’ve identified the cause of the Causes Portal outage and have taken steps to stabilize the platform. User workflows are currently functional, and we are continuing to monitor the situation closely to ensure full resolution.
Posted Mar 18, 2026 - 13:54 MDT

Investigating

Our team is investigating an issue with Okta SSO logins and password resets for the Causes Portal. We're working to resolve this as quickly as possible; please subscribe to this page for the latest updates.
Posted Mar 18, 2026 - 13:06 MDT
This incident affected: Benevity Causes and Nonprofits Portal.