AOGF ACH Configuration Issue
Incident Report for Benevity
Resolved
Issue has been resolved and all donations will follow our standard disbursement cycle.
Posted Mar 25, 2024 - 08:59 MDT
Monitoring
A configuration was mistakenly applied this week to ACH payments to Benevity’s American Online Giving Foundation (AOGF) bank account. As a result, ACH payments sent from March 11-14 may have been rejected. This issue has since been rectified by our banking partner as of March 14, 2024 at 11:30am MT and ACH payments can now be accepted. Wire transfers were not impacted. Payments to other foundations were not impacted.

Please kindly resend payment as soon as possible, either via ACH or wire transfer.

We understand it may take some time for your team to resend payment. We have extended the payment due date from Friday, March 15 to Wednesday, March 20. Rest assured that donations to nonprofits will still be disbursed on the usual timeline (as long as payment is received by March 20).
Posted Mar 14, 2024 - 14:47 MDT
This incident affected: Benevity Global Disbursements.