Card Acceptance Rates to OGF India down
Incident Report for Benevity
Postmortem

Summary

Card acceptance rates on transactions to OGF India were down from 85% to 58%, on average, during the period 5 to 27 March. The average was pulled down by 0% acceptance on 105 attempted stored card transactions. Acceptance rates on 234 simple card transactions remained constant at 85%.

We identified the drop on 26 March and resolved it on 27 March. The first impacted transaction was attempted on 5 Mar.

Donors to OGF India should not have been offered the option to store their card as our particular stored card workflow is not allowed in India, by law,  so the card-issuing banks declined the requests. The issue was resolved by removing the option for donors to request their card be stored.

Impact

Card acceptance rates on transactions to OGF India are down from 85% to 58%, on average, during the period 5 to 27 March. The average was pulled down by 0% acceptance on 105 attempted stored card transactions. Acceptance rates on 234 simple card transactions remained constant at 85%.

Client impact:

    13 clients affected, with the largest impact being 20 users for a singe client.

    51 total users impacted.

Root Cause

Donors to OGF India should not have been offered the option to store their card as our particular stored card workflow is not allowed in India, by law,  so the card-issuing banks declined the requests. 

Benevity's stored card workflow stores cards before charging them. This is not allowed in India. In India, you must charge a card before it is stored. At some point, Benevity may make the workflow change to support stored card in India, until then, we will not present the option on OGF India donors.

Future Mitigation

The issue was resolved by removing the option for donors to request their card be stored. This issue will not recur for this set of donors.

Timeline of Events

  • 5 March - first transaction impacted
  • 26 March - we became aware of the impact following email from BlueSnap
  • 27 March - fix deployed
Posted Apr 11, 2024 - 14:06 MDT

Resolved
This incident has been resolved.
Posted Mar 28, 2024 - 10:44 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 27, 2024 - 12:13 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 26, 2024 - 18:56 MDT
Investigating
We've noticed low acceptance rates for credit/debit card payments to OGF India from stored cards. This only affects OGF India. Transactions fail if the "Store card information for future donations" box is checked or a previously stored card is selected. Other transactions are unaffected. Fix in progress.
Posted Mar 26, 2024 - 18:56 MDT
This incident affected: Benevity Spark.