Some Spark and Alaya users are unable to enter credit card details.
Incident Report for Benevity
Resolved
This incident has been resolved.
Posted May 02, 2024 - 10:07 MDT
Update
We are observing positive results with the fix that has been implemented by our vendor. We will monitor for the remainder of the day and should we continue to see no issues we will mark this issue as resolved.
Posted May 01, 2024 - 11:53 MDT
Update
The fix our vendor has implemented has continued to work and is allowing users to enter payment card details. We will continue to monitor to ensure there are no outstanding issues.
Posted Apr 30, 2024 - 14:38 MDT
Monitoring
Our vendor has implemented a fix for this issue and we are observing successful credit card transactions. We are now monitoring.
Posted Apr 29, 2024 - 14:41 MDT
Update
Our partners have identified a fix and it is being implemented. Next update in 60 minutes.
Posted Apr 29, 2024 - 14:16 MDT
Identified
The issue has been identified and we are working with our partners to implement a fix. Next update in 60 minutes.
Posted Apr 29, 2024 - 11:14 MDT
Investigating
We’re currently investigating an intermittent issue preventing some users from entering credit card details or utilizing Apple Pay for donations. This is a top priority and we’re working swiftly to resolve it. Updates will be posted here as soon as they’re available. Please subscribe to receive notifications for new information. Thank you for your patience.
Posted Apr 29, 2024 - 10:00 MDT
This incident affected: Benevity Spark and Alaya by Benevity.