Upon logging in via SSO, the system might incorrectly prompts the user for a password reset and their old password, blocking the login flow.

Incident Report for Benevity

Resolved

Confirmed and communicated mitigation. Incident resolved.
Posted Aug 06, 2026 - 11:39 MDT

Monitoring

The issue has been mitigated and we are actively monitoring.
Posted Aug 06, 2026 - 11:30 MDT

Identified

Upon logging in via SSO, the system might incorrectly prompt the user for a password reset and their old password, blocking the login flow. The team has identified the issue and is working actively on the mitigation.
Posted Aug 06, 2026 - 11:05 MDT
This incident affected: Donate and Volunteer (formerly Benevity Spark) (Donate and Volunteer Core Services).