External Match Request AI uploader

Incident Report for Benevity

Resolved

We've resolved the issue that caused file uploads to fail for money donations using AI-assisted matching. We've confirmed uploads are working as expected and restored AI matching for all clients.
Posted Jul 06, 2026 - 14:26 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 06, 2026 - 12:23 MDT

Investigating

We're investigating an issue causing file uploads to fail for money donations with AI-assisted matching enabled. We've temporarily disabled AI matching for these donations and reverted to standard processing while we work on a fix. No other donation types are affected.
Posted Jul 06, 2026 - 11:37 MDT
This incident affected: Donate and Volunteer (formerly Benevity Spark) (Donate and Volunteer Core Services).