Versaic Production site experiencing slow performance

Incident Report for Benevity

Resolved

This incident has been resolved.
Posted Apr 06, 2026 - 10:10 MDT

Monitoring

We have identified an issue and have deployed a mitigation. We will continue to monitor the situation but all services are now restored.
Posted Mar 31, 2026 - 15:37 MDT

Update

We are currently experiencing performance issues with the Versaic Admin Portal. Applicant sites are also impacted. Some users may encounter slow page load times or intermittent timeouts.

Our team is actively investigating and working to restore normal performance. We will provide updates as more information becomes available.
Posted Mar 31, 2026 - 14:02 MDT

Investigating

We're currently investigating this issue and will have more details soon. Please subscribe to this page for the latest updates.
Posted Mar 31, 2026 - 13:36 MDT
This incident affected: Grants (Grants Advanced (formerly Versaic)).