Grants Advanced Mail Outage

Incident Report for Benevity

Resolved

This incident has been resolved.
Posted Dec 11, 2025 - 16:38 MST

Update

All mail that was delayed during the outage has now been sent.
Posted Dec 11, 2025 - 16:38 MST

Investigating

There was an outage in mail delivery due to maintenance in our systems.
Posted Dec 11, 2025 - 16:27 MST
This incident affected: Grants (Grants Advanced (formerly Versaic)).