Community Investment Enterprise (Versaic) - Issue Creating New Contact and Changing the Proposal Submitter

Incident Report for Benevity

Resolved

This incident has been resolved.
Posted Aug 07, 2025 - 23:06 MDT

Identified

We've identified the root of the issue and our team is actively implementing a solution to restore full functionality. We appreciate your patience while we work on this. More updates will follow as they become available.
Posted Aug 07, 2025 - 14:52 MDT

Investigating

We are currently investigating an issue where client users cannot create a new contact on the organization profile or change proposal submitter.
Posted Aug 07, 2025 - 14:09 MDT
This incident affected: Community Investment (Enterprise (formerly Versaic by Benevity)).