UKOGF is unable to disburse funds to India
Incident Report for Benevity
Update
We continue to actively work with our banking partners to resolve this issue. We are testing alternative payment railways to ensure donations to India via the UKOGF are processed successfully. To stay informed with the latest updates, please consider subscribing. Your ongoing patience and understanding as we navigate through this challenge are greatly appreciated.
Posted Nov 13, 2024 - 08:19 MST
Update
Update: We continue to actively work with our banking partners to resolve this issue. We are investigating alternative payment railways to ensure donations to India via the UKOGF are processed successfully. To stay informed with the latest updates, please consider subscribing. Your ongoing patience and understanding as we navigate through this challenge are greatly appreciated.
Posted Nov 05, 2024 - 16:31 MST
Identified
On October 22, 2024, we were informed by UKOGF's FX processor, StoneX Group Inc, that they cannot send funds from UKOGF to India due to the Reserve Bank of India (RBI) needing additional information for regulatory compliance. We are actively seeking solutions to resolve the issue and have requested a meeting with in-country counsel to see what might be possible. Please note that this issue does not affect the Online Giving Foundation in India, it only affects cross-border donations going into India from UKOGF.

Until the RBI, StoneX, and UKOGF reach a resolution, disbursements from UKOGF to India will have to be put on hold. This issue is impacting all of UKOGF's banking partners from sending funds to India.

No further action is required from clients at this time. We appreciate your patience and will provide updates as they become available. We'll continue to provide updates here, so please subscribe to this page for the latest information.
Posted Oct 28, 2024 - 13:00 MDT
This incident affects: Benevity Global Disbursements.