Staging Maintenance

Scheduled for Jun 22, 10:00 - 17:00 MDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 18, 2026 - 16:11 MDT

Scheduled

Client staging sites will be unavailable on Monday, June 22 from 10:00 – 17:00 MT. During this window, we will be completing a database upgrade to maintain platform security and stability. No action is required on your part. We'll confirm when the environment is back online.
Posted Jun 18, 2026 - 15:48 MDT
This scheduled maintenance affects: Benevity Staging / Sandbox (Donate and Volunteer (formerly Benevity Spark)).