Employees are unable to upload receipts for match requests

Incident Report for Benevity

Resolved

The issue affecting receipt uploads on Request a Match has been fully resolved, and our team has taken all necessary steps to prevent this from happening again in the future. We apologize for any inconvenience this may have caused.
Posted Sep 10, 2026 - 12:49 MDT

Investigating

We're currently investigating an issue that is preventing employees from uploading receipts on Request a Match. This is affecting all clients. Our team is aware and is working diligently to resolve the issue as quickly as possible. We'll continue to provide updates here, so please subscribe to this page for the latest information.
Posted Sep 10, 2026 - 12:11 MDT
This incident affected: Donate and Volunteer (formerly Benevity Spark) (Donate and Volunteer Core Services).