Group of private non-operating organizations in the US are currently unavailable

Incident Report for Benevity

Postmortem

Summary

On Tuesday, June 17, 2025, at 4:00 AM MDT, an unintended system behavior resulted in the temporary deactivation of approximately 108,000 U.S.-based “Private Non-Operating” nonprofit organizations from the Benevity platform. This occurred during a routine update process using IRS-provided data.

As a result, affected organizations were temporarily marked as ineligible to receive donations, rewards, or matching funds through our platform. The issue was reported at 10:35 AM MDT the same day, and by June 18 at 10:24 AM MDT, all impacted nonprofits were restored to active status.

Benevity teams worked with urgency and diligence to resolve the issue and minimize downstream effects for both nonprofits and donors. We recognize the importance of uninterrupted eligibility for these organizations and have already taken steps to ensure stronger protections going forward.

Impact

Approximately 108,000 U.S. “Private Non-Operating” nonprofit organizations were temporarily deactivated between 4:00 AM MDT on June 17 and 10:24 AM MDT on June 18. During this time period:

  • These nonprofits were unable to receive new donations, rewards, or matching contributions while inactive.
  • Recurring payroll donations were not impacted and continued to flow without interruption.
  • End users may notice a status update (from deactivated to active) in their donation history for affected organizations.

Root Cause

In April 2025, Benevity deployed an enhancement to support the ingestion of a new classification of IRS nonprofit data, including “Private Non-Operating” organizations, adding roughly 125,000 new organizations to the platform.

However, during the June 17 IRS data update, the system inadvertently used a legacy configuration that did not include support for this new classification. As a result, these organizations were incorrectly flagged as absent from the official data and automatically deactivated in our ecosystem.

Upon identifying the configuration discrepancy, our team reprocessed the IRS data using the correct, up-to-date configuration. This fully restored eligibility status for all affected organizations.

Future Mitigation

To reduce the likelihood of recurrence and reinforce data integrity, Benevity is taking the following steps:

  • Removal of outdated configurations from the system to prevent accidental use in future IRS data updates.
  • Enhanced anomaly detection: Revisiting thresholds and alerting logic to detect and flag unusually large volumes of deactivations or data changes during synchronization.
  • Automated safeguards: Strengthening pre-processing validation rules for third-party data ingestion, with a focus on nonprofit classification changes.

Timeline of Events

June 17, 2025

  • 4:00am MDT - System deactivation begins
  • 10:35am MDT - Deactivations are detected
  • 11:05am MDT - Investigation and remediation efforts begin

Jun 18, 2025

  • 10:24am MDT - Restoration of all deactivated organizations completed
  • 2:42pm MDT - Incident resolved
Posted Jun 26, 2025 - 15:51 MDT

Resolved

At this time all impacted private non-operating organizations are available in the platform.
Posted Jun 18, 2025 - 10:52 MDT

Identified

We have identified the root-cause of the issue and a correction is being applied. At this time, the majority of impacted private non-operating organizations are available in the platform.
Posted Jun 18, 2025 - 07:58 MDT

Investigating

A group of private non-operating organizations in the US are currently unavailable in the platform. We have identified the root cause and are working to implement a fix.
Posted Jun 17, 2025 - 13:43 MDT
This incident affected: Benevity Platform.