As of October 11, 2025, Canada Post has transitioned to a nationwide rotating strike. Mail pickup and delivery have resumed but delays are expected during this period. We continue to encourage nonprofits to switch to EFT to help minimize disbursement delays. Benevity will monitor the situation closely and provide further updates as needed. For more information, please reach out to your Benevity Client Success Manager.
Posted Oct 14, 2025 - 22:53 MDT
Identified
As of September 25, 2025, Canada Post announced a service disruption affecting mail, including checks mailed from Canada to Canadian non-profits. To minimize disbursement delays, impacted nonprofits are encouraged to switch to EFT. We recognize the importance of timely funding, especially during Giving Season. We will continue to monitor the situation and provide updates until Canada Post mail service resumes. For more information, please reach out to your Benevity Client Success Manager.
Posted Oct 02, 2025 - 16:38 MDT
This incident affects: Benevity Global Disbursements.