Applicants are Unable to Submit Forms in CI Essentials (formerly Benevity Grants)

Incident Report for Benevity

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 13:09 MDT

Monitoring

We have taken action to correct the issue; functionality has been restored and we are monitoring for any further issues or reoccurrences
Posted Jul 10, 2025 - 12:58 MDT

Investigating

We are currently investigating an issue where applicants are unable to submit forms in Community Investment Essential (formerly Benevity Grants).
Posted Jul 10, 2025 - 12:50 MDT
This incident affected: Community Investment (Essential (formerly Benevity Grants)).