Inconsistent load times for Volunteering pages within our Employee Engagement product

Incident Report for Benevity

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 15:44 MDT

Monitoring

Impacted services have returned to normal availability. We continue to monitor.
Posted Oct 29, 2025 - 13:09 MDT

Update

We are observing an improvement in service as the underlying cause is remediated. We continue to investigate impact.
Posted Oct 29, 2025 - 12:52 MDT

Identified

The issue has been identified, we are working to mitigate the issue and restore service.
Posted Oct 29, 2025 - 11:48 MDT

Investigating

We are experiencing inconsistent load times for Volunteering pages within our Employee Engagement product. We are currently investigating the issue.
Posted Oct 29, 2025 - 11:26 MDT
This incident affected: Donate and Volunteer (formerly Benevity Spark), Benevity Causes and Nonprofits Portal and Community Investment (Enterprise (formerly Versaic by Benevity)).