Alaya Email Services Unavailable

Incident Report for Benevity

Resolved

This incident has now been resolved.
Posted Apr 15, 2026 - 11:37 MDT

Monitoring

The fix has been implemented and has been tested and confirmed as working. Email services in Alaya should now be operating as normal.
Posted Apr 15, 2026 - 11:04 MDT

Identified

This issue has been identified and the teams are working to implement a fix.
Posted Apr 15, 2026 - 08:24 MDT

Investigating

We are currently investigating an issue in with Alaya emails. Certain platform functionality may not work as a result.
Posted Apr 15, 2026 - 08:00 MDT
This incident affected: Alaya by Benevity.