Causes Site: Terms of Use Acceptance
Incident Report for Benevity
Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 09:14 MDT
Monitoring
The issue has been addressed. We are currently monitoring the impacted users to ensure a smooth resolution.
Posted Apr 10, 2024 - 11:33 MDT
Investigating
Some cause users are encountering an 'error: unknown error sending a request' message when accepting Terms of Use. The team is working on a fix.
Posted Apr 10, 2024 - 10:08 MDT
This incident affected: Benevity Causes and Nonprofits Portal.