Versaic: Refunds are failing to process for Payments sent through Benevity.
Incident Report for Benevity
Resolved
This incident has been resolved. All systems are fully operational and no further occurrences have been detected.
Posted Apr 17, 2024 - 16:04 MDT
Monitoring
The issue has been identified and we have applied a temporary fix to reduce the impact. Teams are working on a permanent solution.
Posted Apr 17, 2024 - 10:34 MDT
This incident affected: Versaic by Benevity (Versaic Production Application).