UKOGF India Processing Delays
Incident Report for Benevity
Identified
We’ve identified a solution to successfully disburse donations to India through The UK Online Giving Foundation (UKOGF). All delayed funds will be included in this month's disbursement, which we anticipate completing by the end of April. Thank you for your patience as we continue to address and resolve the underlying issue. We will continue to monitor the disbursements to ensure they successfully reach the nonprofits.
Posted Apr 23, 2024 - 16:27 MDT
Update
We continue to actively work with our banking partner to resolve this issue. Our banking partner has connected with the State Bank of India and we are awaiting additional information. To stay informed with the latest updates, please consider subscribing. Your ongoing patience and understanding as we navigate through this challenge are greatly appreciated.
Posted Apr 03, 2024 - 16:40 MDT
Update
We are actively working with our banking partner to expedite the resolution of this issue. To stay informed with the latest updates, please consider subscribing. Your ongoing patience and understanding as we navigate through this challenge are greatly appreciated.
Posted Mar 22, 2024 - 11:43 MDT
Investigating
We've identified a payment processing issue affecting certain donations made to nonprofits in India through The UK Online Giving Foundation (UKOGF). This issue has resulted in the rejection of nonprofit payments by the bank, specifically impacting the donations that were disbursed at the end of February. As a result, these funds have been returned to the UKOGF account.

We’ve escalated this issue with our banking partner for immediate investigation. We will provide an update as soon as we have more details on the resolution.

Thank you for your understanding as we work diligently to resolve this matter.
Posted Mar 14, 2024 - 15:43 MDT
This incident affects: Benevity Global Disbursements.