Benevity Grants: Benevity Grants is experiencing an issue where multiple clients are unable to save a payment card.
Incident Report for Benevity
Resolved
This incident has been resolved.
Posted Apr 23, 2024 - 14:54 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2024 - 14:35 MDT
Identified
The issue has been identified and a fix is being implemented. The fix will be deployed today by 5 PM MST.
Posted Apr 23, 2024 - 14:06 MDT
This incident affected: Benevity Grants (Benevity Grants).