Ukraine Central Bank Payment Suspension
Incident Report for Benevity
Resolved
Benevity is continuing to monitor the situation with our ongoing processes. This incident is considered resolved.
Posted Jun 09, 2022 - 14:29 MDT
Monitoring
Ukrainian causes are now available for donations following additional review of sanctions, regulations and risks related to the situation in Ukraine and consultations with our financial partners to ensure we can safely send donations to Ukraine. We’ve updated the banner on applicable Spark sites to reflect this new development, and will update the banner with additional languages shortly.
Posted Mar 02, 2022 - 16:59 MST
Update
Ukrainian nonprofits have been temporarily deactivated in the Benevity Causes Portal, due to the suspension of Ukraine’s currency markets. Donations in progress will be reversed back into users’ accounts so they can redirect funds to organizations that are able to accept donations. We’ve added a banner to your spark site that explains how your employees can still support the people of Ukraine through your program. We plan to update the banner with additional languages as time progresses. If you’d like to edit or remove your banner, please contact help@benevity.com
Posted Feb 28, 2022 - 15:26 MST
Update
The situation in Ukraine escalated quickly, and millions of people are facing a terrible humanitarian crisis. Thousands of Ukrainians have fled their homes with very little, and people are looking for a way to help by donating funds.
The Ukrainian government has suspended its currency, making it impossible for us to confidently disburse donations to nonprofits based in the area. As a result, Benevity has made the difficult decision to temporarily deactivate the ability to donate to Ukrainian organizations on our platform.
For the donations that were in progress, we are in the process of putting the funds back into the accounts of those who have donated so they can help by redirecting these funds to organizations based in other countries that are able to accept donations and have support on the ground in Ukraine or are supporting people from outside of the country with refugee resettlement.
Posted Feb 27, 2022 - 11:05 MST
Identified
Due to recent events in Ukraine, the landscape is evolving quickly and frequently. Sanctions and regulations are being imposed and in order to maintain confident and certainty with donations, we have temporarily deactivated all causes that have increased regulatory and sanction scrutiny. We are also in the process of reversing all donations that cannot be completed due to the change in landscape.
Posted Feb 26, 2022 - 07:43 MST
Investigating
Due to the recent events in Ukraine, the Ukrainian Central Bank has suspended disbursements to Ukraine. We are investigating into the situation for next steps and actions. Communications to the affected stakeholders will be sent as we have clarity and guidance.
Posted Feb 24, 2022 - 17:50 MST
This incident affected: Benevity Spark.