Reporting Services
Incident Report for Benevity
Resolved
This incident has been resolved.
Posted 14 days ago. Nov 30, 2018 - 11:15 MST
Update
Reporting services are now available.
Posted 15 days ago. Nov 29, 2018 - 23:40 MST
Update
We continue to investigate the outage to our reporting services. Updates to follow every 30 minutes until the issue is resolved.
Posted 15 days ago. Nov 29, 2018 - 23:23 MST
Investigating
We are investigating an outage with our reporting services. An update will come in 15 minutes.
Posted 15 days ago. Nov 29, 2018 - 23:10 MST
This incident affected: Benevity Reporting.