Russian Sanctions
Incident Report for Benevity
Resolved
Benevity is continuing to monitor the situation with our ongoing processes. This incident is considered resolved.
Posted Jun 09, 2022 - 14:29 MDT
Update
Many countries have imposed sanctions against Russia and Belarus, and as a result, Russian or Belarusian nonprofit organizations have been temporarily deactivated from the Benevity Causes Portal. We are in the process of putting funds back into the accounts of those who have donated so they can redirect funds to other organizations that are able to accept donations.
Posted Feb 28, 2022 - 15:26 MST
Update
The situation in Ukraine has escalated quickly, and millions of Ukrainians are facing a terrible humanitarian crisis.
Due to this, many countries have imposed sanctions against Russia and Belarus. To comply with these sanctions, donations cannot be made to Russian or Belarusian nonprofit organizations, and Benevity has deactivated these organizations on our platform, meaning they are not available to donate to at this time.
We are in the process of putting funds back into the accounts of those who have donated so they can help by redirecting these funds to other organizations based in other countries that are able to accept donations.
Posted Feb 27, 2022 - 11:05 MST
Identified
Due to the recent sanctions on Russia/Belarus, we have taken measures to avoid any undue risk to our clients and users. We have deactivated all sanctioned causes from our portfolio of causes as well as reversing all in-flight transactions that were made.
Posted Feb 26, 2022 - 07:44 MST
Investigating
Due to the recent sanctions on Russia/Belarus, we are investigating into the pending transactions and taking the appropriate steps and measures.
Posted Feb 24, 2022 - 17:49 MST
This incident affected: Benevity Spark.