Intermittent issue submitting Forms to Grants
Incident Report for Benevity
Postmortem

Summary

On December 1 and 2, 2022 Benevity Grants experienced intermittent periods where some users would have presented with an error page when accessing resources within the site. The logging service that is used by Benevity Grants was experiencing higher than expected volumes of traffic, which resulted in downstream impact to the Benevity Grants application. Resources have been increased on the logging service and the service has been fully isolated from Benevity Grants so that any impacts to the logging service do not cause service interruptions for users on Benevity Grants.

Impact

Benevity Grants users were able to login to the site, but may have experienced intermittent error pages being displayed when accessing resources within the site. During this time, Grants applicants also intermittently received error messages that their application forms failed to submit.

Root Cause

During a period of higher than expected traffic, some instances of an internal logging service ran out of resources, and were unable to handle incoming requests. The Grants application detected the issues with the logging service and attempted to automatically restore the service. During the recovery, some instances of the Grants application displayed error messages to users as they were navigating the site.

Future Mitigation

Resources were increased for the logging service to ensure it could keep up with heavy demand during high traffic periods for the Grants application. Additionally, the logging service was reconfigured and isolated from the Grants application so that errors in the logging service will not impact or interrupt user traffic to the Grants application.

Timeline of Events

  • December 1 9:40MT - Initial alert received
  • December 1 12:12MT - Cause identified
  • December 2 10:51MT - Partial fix deployed to production; monitoring
  • December 2 11:46MT - Second alert received
  • December 2 12:38MT - Fix deployed to production; Incident resolved
Posted Dec 22, 2022 - 16:29 MST

Resolved
This incident has been resolved.
Posted Dec 05, 2022 - 17:47 MST
Monitoring
A fix has been implemented and we are seeing that services are responding as expected. We will continue to monitor the results
Posted Dec 05, 2022 - 16:32 MST
Identified
We have identified an issue submitting forms to the Grants application. The Grants application is working but form submission is having issues. We are looking into the problem
Posted Dec 05, 2022 - 16:11 MST
This incident affected: Benevity Grants (Benevity Grants Forms).